Bit of a wierd one here. Calls going to a group weren't following the overflow timer.
Normal group. Unconditional Ring. Next port set to the BI-VMS port. Overflow set toe 20. Group Busy and All Out Next both set to on. 4 digital and 6 sip members.
FS/FT set for calls from that group to go to a mailbox.

Calls would just sit playing the hold music without overflowing to the VM.

Checked the activity log and it shows a successful transfer from the Main menu to the station group. It says SVMi-20E hanging up.
When I look at the connection status for that trunk though it still says it is connected to a VM port. Oddly that VM port shows connected to a different Trunk / call.

I tried changing the group busy and all out next to off and there was no change. Adjusted the overflow too.

I then figured it might be an issue with the group being a mix of digital and sip so I removed the SIP extensions and tested it. Worked fine. Added the sip extensions back in and it continued to work.

So, fix achieved? But I don't get why.

Has anyone else had issues with mixed station groups like that?